Auteur Sujet: Compteur qui disparait  (Lu 403 fois)

Hors ligne Raoul

  • Très assidu
  • ***
  • Messages: 116
Compteur qui disparait
« le: 16 septembre 2016 - 22:22:30 pm »
Bonjour,

Alors, je rencontre un drôle de soucis.
J'ai enfin posé le compteur pour ma PAC et je le monitor avec le module USB recommandé en page d’accueil ( http://gce-electronics.com/fr/usb/655-module-teleinfo-usb.html ).

Après une détection des interfaces, RAS, tout marche...pendant quelques temps.

Après un reboot de mon serveur suite mise à jour Windows, le compteur disparaît. Dans iTow, il me donne bien l'ID du compteur est marque à coté INEXISTANT.

Quelqu'un à déjà été confronté au soucis ?

Je viens de mettre les pilotes à jour, pas mieux.............

En ligne Lucien77

  • Moderator
  • Scotché
  • *****
  • Messages: 2285
  • Sexe: Homme
Re : Compteur qui disparait
« Réponse #1 le: 16 septembre 2016 - 22:28:57 pm »
 ^-^

As-tu essayé d'inverser les compteurs par rapport aux interfaces ?

Hors ligne Raoul

  • Très assidu
  • ***
  • Messages: 116
Re : Compteur qui disparait
« Réponse #2 le: 16 septembre 2016 - 22:32:03 pm »
Oui, j'ai tenter. J'ai 3 interfaces en tout, j'attends un nouveau compteur pour mon ECS.
J'ai donc changé l'interface, sans succès.

Le premier "cas" est apparu hier. En changeant l'interface, pas mieux. A force de reboot des interface et du PC; le compteur était revenu. jusqu’à ce soir et un reboot du PC.


En ligne Lucien77

  • Moderator
  • Scotché
  • *****
  • Messages: 2285
  • Sexe: Homme
Re : Compteur qui disparait
« Réponse #3 le: 16 septembre 2016 - 22:38:08 pm »
Quand je disais inverser, c'était de croiser les compteurs.
Mettre le compteur général sur l'interface de la PAC et le compteur de la PAC sur l'interface du général.
Parce que, si j'ai bien compris, c'est le compteur PAC qui disparait, pas le compteur général ?

Hors ligne Raoul

  • Très assidu
  • ***
  • Messages: 116
Re : Compteur qui disparait
« Réponse #4 le: 16 septembre 2016 - 23:10:19 pm »
C'est vrai que je n'ai pas tester cela.

J'ai inverser les 2 interfaces (PAC et celle prèvue pour l'ECS) mais je n'ai pas inverser avec le compteur général.

Je vais tester cela demain, et je te tiens au courant.

 :dodo:

En ligne Lucien77

  • Moderator
  • Scotché
  • *****
  • Messages: 2285
  • Sexe: Homme
Re : Compteur qui disparait
« Réponse #5 le: 16 septembre 2016 - 23:15:42 pm »
Oui, ça permettra de lever le doute sur le compteur PAC.

A demain donc

Hors ligne Raoul

  • Très assidu
  • ***
  • Messages: 116
Re : Compteur qui disparait
« Réponse #6 le: 17 septembre 2016 - 09:46:39 am »
 ^-^

Interface permutée à l'instant même, çà semble tenir le coup. Les 2 compteurs sont de retour. A voir dans le temps si ça passe le week end et quelques reboot.

@ELF, on reçoit bien une alerte mail quand iTow n'envoie pas de mesure, mais possible de faire le même genre d'alerte quand un compteur n’émet plus ? Ça permettrait de s'en apercevoir plus rapidement.


En ligne Lucien77

  • Moderator
  • Scotché
  • *****
  • Messages: 2285
  • Sexe: Homme
Re : Compteur qui disparait
« Réponse #7 le: 17 septembre 2016 - 09:58:30 am »
 ^-^

On ne voit que le compteur PAC ?

Hors ligne Raoul

  • Très assidu
  • ***
  • Messages: 116
Re : Compteur qui disparait
« Réponse #8 le: 17 septembre 2016 - 10:01:04 am »
Exact, ca tiens 2 reboot.. pfff...

Je viens de voir que iTow cherche sur le port COM2 et COM3 alors que dans le gestionnaire de peripherique, j'ai COM2 / 3 et 5 (le 4 nest pas activé reserver pour l'interface ECS)

iTow ne va pas chercher sur le COM5 qui est mon compteur manquant. Et quand je test la téléinfo sur COM5 j'ai le message port occupé. Comprends plus rien !!

En ligne Lucien77

  • Moderator
  • Scotché
  • *****
  • Messages: 2285
  • Sexe: Homme
Re : Compteur qui disparait
« Réponse #9 le: 17 septembre 2016 - 10:17:53 am »
Essaye de changer l'interface de port USB

Hors ligne Raoul

  • Très assidu
  • ***
  • Messages: 116
Re : Compteur qui disparait
« Réponse #10 le: 17 septembre 2016 - 11:13:21 am »
Après des milliers de tests, j'ai fini par trouver...

L'interface CGE pose soucis. J'ai tout essayer, supprimer ports et pilotes, inverser les téléinfo, changé le cable USB et intervertit les ports, toujours au reboot, iTow refuse d'aller tester le COM ou est branché l'interface CGE.

Je vais creuser une fois le compteur ECS en place. Là, j'ai un téléinfonstick et une vielle interface sans nom, sans marque et sans boite, et ca roule après les reboot, toujours là !

Je mettrai le compteur ECS sur l'interface CGE une fois ce dernier branché, et je ferrai quelques tests avec les vitesses et les parités dans les reglages du port. Wait and see.

Merci de ton aide !

Hors ligne elf

  • Administrator
  • Scotché
  • *****
  • Messages: 2117
  • Sexe: Homme
    • iTow - Intégré Téléinfo One Wire
Re : Compteur qui disparait
« Réponse #11 le: 17 septembre 2016 - 12:02:17 pm »
 ^-^

C'est ce genre d'interface ? http://gce-electronics.com/fr/nos-produits/20-convertisseur-usb-vers-rs232-ttl.html
dans l'affirmative, as-tu installé le driver FTDI ?
elf - admin
Me contacter uniquement par mail,
les MP à ma destination sont désactivés.

Hors ligne Raoul

  • Très assidu
  • ***
  • Messages: 116
Re : Compteur qui disparait
« Réponse #12 le: 17 septembre 2016 - 12:25:56 pm »
 ^-^

C'est celle ci : http://gce-electronics.com/fr/usb/655-module-teleinfo-usb.html

Les drivers sont parfaitement installer, aucuns soucis niveau pilote.
Le problème se situe au niveau au reboot, iTow ne scanne plus le port COM créer par cette interface.
Là, je l'ai supprimer en attendant de recevoir mon compteur pour l'ECS. Je la brancherait à ce moment et je ferrais quelques tests avec les vitesses et les paritées. Voir si le soucis ne viens pas de là.

Si le soucis se représente au moment du branchement, je ferrai un nouveau sujet   :'(